Microsoft 070-764日本語 Actual Free Exam Questions & Community Discussion
概要
あなたはLitware、Incという会社のデータベース管理者です。
Litwareは本の出版社です。 Litwareには本社と支店があります。
開発中の新しいWebベースのアプリケーションをサポートするようにデータベースインフラストラクチャを設計しています。
Webアプリケーションはwww.litwareinc.comでアクセスされます。社内の従業員と社外のパートナーの両方がこのアプリケーションを使用します。
App1_DBという名前のSQL Server 2008データベースを使用する既存のデスクトップアプリケーションがあります。
App1_DBは運用環境に残ります。
必要条件
計画された変更
Database1とDatabase2という2つのデータベースを含むSQL Server 2014インスタンスを展開することを計画しています。
すべてのデータベースファイルは、可用性の高いSANに保存されます。
Database1には、OrdersとOrderDetailsという2つのテーブルが含まれます。
Database1には、usp_UpdateOrderDetailsという名前のストアドプロシージャも含まれます。
ストアドプロシージャは注文情報を更新するために使用されます。ストアドプロシージャは、プロシージャが実行されるたびにOrdersテーブルを2回クエリします。
最初のクエリから返された行は、2回の読み込み操作の間にテーブルに追加された行と共に、2番目のクエリで変更されずに返される必要があります。
Database1には、Database2テーブルのデータにアクセスするいくつかのクエリが含まれます。
Database2にはInventoryという名前のテーブルが含まれます。
在庫には100 GBを超えるデータが含まれます。
Inventoryテーブルには、主キーのクラスタ化インデックスと非クラスタ化インデックスの2つのインデックスがあります。
主キーとして使用される列は、identityプロパティを使用します。
Database 2 wiltには、usp_UpdateInventoryという名前のストアドプロシージャが含まれています。 usp_UpdateInventoryは、無制限の階層数を持つ自己結合を含むテーブルを操作します。 Database2のすべてのデータは毎日再作成され、広告は次のデータ作成プロセスまで変更されません。 Database2からのデータは、Application1という名前の外部アプリケーションによって定期的にアクセスされます。 Database2のデータが変更されるとすぐに、Database2のデータはAppl_Dblという名前のデータベースに送信されます。 Litwareは、すべてのSQL Server 2014バックアップにオフサイトストレージを使用する予定です。
ビジネス要件
以下の要件があります。
* 新しいライセンスの費用は最小限に抑える必要があります。
* アプリケーションからアクセスされる個人情報は安全な形式で保存する必要があります。
* 開発努力は可能な限り最小限に抑える必要があります。
* データベースのストレージ要件は最小限に抑える必要があります。
システム管理者は、ディスク使用量に関するリアルタイムレポートを実行できなければなりません。
* SQL Serverサービスが失敗した場合、データベースは利用可能でなければなりません。
* データベース管理者は、割り当てエラーとデータ破損を含む詳細レポートを受け取る必要があります。
* アプリケーション開発者はデータベーステーブルへの直接アクセスを拒否されなければなりません。アプリケーションはテーブルへの直接アクセスを拒否されなければなりません。
法規制の順守要件を満たすために、バックアップファイルを暗号化する必要があります。
暗号化戦略では、データベースとアプリケーションに対する変更を最小限に抑える必要があります。
あなたはDatabase2をApp1_Db1に同期させるための解決策を推奨する必要があります。何をお勧めですか?
あなたはLitware、Incという会社のデータベース管理者です。
Litwareは本の出版社です。 Litwareには本社と支店があります。
開発中の新しいWebベースのアプリケーションをサポートするようにデータベースインフラストラクチャを設計しています。
Webアプリケーションはwww.litwareinc.comでアクセスされます。社内の従業員と社外のパートナーの両方がこのアプリケーションを使用します。
App1_DBという名前のSQL Server 2008データベースを使用する既存のデスクトップアプリケーションがあります。
App1_DBは運用環境に残ります。
必要条件
計画された変更
Database1とDatabase2という2つのデータベースを含むSQL Server 2014インスタンスを展開することを計画しています。
すべてのデータベースファイルは、可用性の高いSANに保存されます。
Database1には、OrdersとOrderDetailsという2つのテーブルが含まれます。
Database1には、usp_UpdateOrderDetailsという名前のストアドプロシージャも含まれます。
ストアドプロシージャは注文情報を更新するために使用されます。ストアドプロシージャは、プロシージャが実行されるたびにOrdersテーブルを2回クエリします。
最初のクエリから返された行は、2回の読み込み操作の間にテーブルに追加された行と共に、2番目のクエリで変更されずに返される必要があります。
Database1には、Database2テーブルのデータにアクセスするいくつかのクエリが含まれます。
Database2にはInventoryという名前のテーブルが含まれます。
在庫には100 GBを超えるデータが含まれます。
Inventoryテーブルには、主キーのクラスタ化インデックスと非クラスタ化インデックスの2つのインデックスがあります。
主キーとして使用される列は、identityプロパティを使用します。
Database 2 wiltには、usp_UpdateInventoryという名前のストアドプロシージャが含まれています。 usp_UpdateInventoryは、無制限の階層数を持つ自己結合を含むテーブルを操作します。 Database2のすべてのデータは毎日再作成され、広告は次のデータ作成プロセスまで変更されません。 Database2からのデータは、Application1という名前の外部アプリケーションによって定期的にアクセスされます。 Database2のデータが変更されるとすぐに、Database2のデータはAppl_Dblという名前のデータベースに送信されます。 Litwareは、すべてのSQL Server 2014バックアップにオフサイトストレージを使用する予定です。
ビジネス要件
以下の要件があります。
* 新しいライセンスの費用は最小限に抑える必要があります。
* アプリケーションからアクセスされる個人情報は安全な形式で保存する必要があります。
* 開発努力は可能な限り最小限に抑える必要があります。
* データベースのストレージ要件は最小限に抑える必要があります。
システム管理者は、ディスク使用量に関するリアルタイムレポートを実行できなければなりません。
* SQL Serverサービスが失敗した場合、データベースは利用可能でなければなりません。
* データベース管理者は、割り当てエラーとデータ破損を含む詳細レポートを受け取る必要があります。
* アプリケーション開発者はデータベーステーブルへの直接アクセスを拒否されなければなりません。アプリケーションはテーブルへの直接アクセスを拒否されなければなりません。
法規制の順守要件を満たすために、バックアップファイルを暗号化する必要があります。
暗号化戦略では、データベースとアプリケーションに対する変更を最小限に抑える必要があります。
あなたはDatabase2をApp1_Db1に同期させるための解決策を推奨する必要があります。何をお勧めですか?
Correct Answer: D
Vote an answer
Explanation: Only visible for EduDump members. You can sign-up / login (it's free).
次のファイルグループを使用するDB1という名前のデータベースを管理します。

データベースは、完全復旧モデルを使用するように構成されています。 トランザクションログは、TLogBackupという名前のバックアップセットにバックアップされます。
DB1のPRIMARYおよびFG2
上記の要件をすべて満たす断片的な復元計画を設計する必要があります。 重要なファイルグループをできるだけ早くオンラインにして、復元時間を最小限に抑える必要があります。 復元操作が完了した後、破損したファイルグループはすべてオンラインにする必要があります。
どの5つのアクションを順番に実行する必要がありますか? 回答するには、アクションのリストから適切なアクションを回答エリアに移動し、正しい順序に並べます。


データベースは、完全復旧モデルを使用するように構成されています。 トランザクションログは、TLogBackupという名前のバックアップセットにバックアップされます。
DB1のPRIMARYおよびFG2
上記の要件をすべて満たす断片的な復元計画を設計する必要があります。 重要なファイルグループをできるだけ早くオンラインにして、復元時間を最小限に抑える必要があります。 復元操作が完了した後、破損したファイルグループはすべてオンラインにする必要があります。
どの5つのアクションを順番に実行する必要がありますか? 回答するには、アクションのリストから適切なアクションを回答エリアに移動し、正しい順序に並べます。

Correct Answer:

Explanation

Step 1: Perform a differential database backup...
Step 2: Perform a tail-log backup...
A tail-log backup captures any log records that have not yet been backed up (the tail of the log) to prevent work loss and to keep the log chain intact. Before you can recover a SQL Server database to its latest point in time, you must back up the tail of its transaction log. The tail-log backup will be the last backup of interest in the recovery plan for the database.
Step 3:
The PRIMARY and FG2 for DB1 are damaged. FG1 and FG3 are intact.
Step 4:
Transaction logs are backed up to a backup set named TLogBackup.
Step 5:
The PRIMARY and FG2 for DB1 are damaged.
References:
https://docs.microsoft.com/en-us/sql/relational-databases/backup-restore/restore-files-and-filegroups-sql-server?v
https://docs.microsoft.com/en-us/sql/relational-databases/backup-restore/tail-log-backups-sql-server?view=sql-se
Microsoft SQL Server 2016インスタンスをインストールする予定です。
インスタンスは、次の要件を満たすデータベースをサポートします。
* Excelワークブックをファイルシステムに保存します。
* Transact-SQLを介してワークブックにアクセスします。
* データベースのバックアップにワークブックを含めます。
* インストール中に、要件が満たされていることを確認する必要があります。
どの機能を使うべきですか?
インスタンスは、次の要件を満たすデータベースをサポートします。
* Excelワークブックをファイルシステムに保存します。
* Transact-SQLを介してワークブックにアクセスします。
* データベースのバックアップにワークブックを含めます。
* インストール中に、要件が満たされていることを確認する必要があります。
どの機能を使うべきですか?
Correct Answer: B
Vote an answer
あなたはContoso、Ltdのデータベース管理者です。グローバルセールスアプリケーションを開発環境から本番環境に移行する準備をしています。
Salesという名前のスキーマを持つContosoという名前のデータベースがあります。データベース内のすべてのオブジェクトは同じ所有者を持ちます。スキーマには多数のビューとストアドプロシージャがあります。どのストアード・プロシージャーもIDENTITY_INSERT操作または動的SQLコマンドを実行しません。 WITH SCHEMABINDINGオプションを使用してすべてのビューを作成します。
営業部門のすべての従業員は、Contoso \ Salesという名前のActive Directoryドメインサービス(AD DS)セキュリティグループのメンバーです。
次のデータベースオブジェクトは、Contoso \ Salesのユーザーがアプリケーションを使用しているときに照会される唯一のオブジェクトです。
ビュー
* SalesReport
* SalesInvoice
ストアドプロシージャ
* InvoiceExecute - 読み取り/書き込み操作を実行します
* InvoiceSearch - 読み取り専用操作を実行します
データベースに権限を付与するときは、最小特権の原則を使用する必要があります。
SalesRoleという名前の新しいユーザー定義データベースロールを作成し、SalesRoleのメンバとしてContoso \ Salesを追加します。
営業部門の全従業員に、ビューとストアドプロシージャを使用する権限を付与する必要があります。
どの2つのソリューションが要件を満たしますか?正解はそれぞれ完全な解決策を提示します。
Salesという名前のスキーマを持つContosoという名前のデータベースがあります。データベース内のすべてのオブジェクトは同じ所有者を持ちます。スキーマには多数のビューとストアドプロシージャがあります。どのストアード・プロシージャーもIDENTITY_INSERT操作または動的SQLコマンドを実行しません。 WITH SCHEMABINDINGオプションを使用してすべてのビューを作成します。
営業部門のすべての従業員は、Contoso \ Salesという名前のActive Directoryドメインサービス(AD DS)セキュリティグループのメンバーです。
次のデータベースオブジェクトは、Contoso \ Salesのユーザーがアプリケーションを使用しているときに照会される唯一のオブジェクトです。
ビュー
* SalesReport
* SalesInvoice
ストアドプロシージャ
* InvoiceExecute - 読み取り/書き込み操作を実行します
* InvoiceSearch - 読み取り専用操作を実行します
データベースに権限を付与するときは、最小特権の原則を使用する必要があります。
SalesRoleという名前の新しいユーザー定義データベースロールを作成し、SalesRoleのメンバとしてContoso \ Salesを追加します。
営業部門の全従業員に、ビューとストアドプロシージャを使用する権限を付与する必要があります。
どの2つのソリューションが要件を満たしますか?正解はそれぞれ完全な解決策を提示します。
Correct Answer: B,D
Vote an answer
注:この質問は、同じシナリオを使用する一連の質問の一部です。便宜上、質問ごとにシナリオが繰り返されます。各質問には異なる目標と回答の選択肢がありますが、このシリーズの各質問では次のシナリオはまったく同じです。
繰り返されるシナリオの開始
Contoso、Ltd.には、カスタムアプリケーションをサポートするMicrosoft SQL Serverデータベースがあります。現在のSQL Server環境は、ContosoSQL1とContosoSQL2の2つのサーバーで構成されています。これら2つのサーバーは、自動フェールオーバーで同期コミットを使用するように構成されたContosoAG1という名前のAlways On可用性グループに参加します。セカンダリレプリカは読み取り専用アクセス用に構成されていません。
アプリケーションは、ContosoDBという名前のデータベースでトランザクション処理と履歴データ取得の両方を実行します。アプリケーションには、在庫管理モジュールが含まれています。インベントリ管理モジュールとデータベースでパフォーマンスの問題が発生しています。
ユーザーは、InventoryQuery1という名前のクエリの完了に時間がかかると報告しています。クエリは次のように表示されます。
SELECT ProductNumber、Name、ProductLine
FROM Production.Product
WHERE ProductNumber = N '<特定の製品>'
このクエリに対してSQL Serverが使用するクエリプランは、展示に示されています。 ([展示]タブをクリックします。)頻繁に長期にわたってブロックされるエピソードなど、さまざまなパフォーマンスの問題により、ビジネスユーザーは日常のタスクを完了できません。 tempdbデータベースリソースが原因であると思われます。問題を特定するには、ContosoDBデータベースのブロッキングレポートを作成する必要があります。
示す。

拡張イベントを使用して、ContosoSQL1インスタンスに対して実行されるすべてのTransact-SQLステートメントを確認する予定です。拡張イベントセッションからの出力には、開始イベントと停止イベントの両方が含まれている必要があり、ファイルに書き込む必要があります。データ損失の可能性を最小限に抑え、サーバーのパフォーマンスへの影響を減らすために、拡張イベントセッションを構成する必要があります。
ContosoSQL3という名前の追加のセカンダリレプリカをContosoAG1に展開する予定です。読み取り専用トラフィックは、どのインスタンスがプライマリレプリカであるかに関係なく、2つのセカンダリレプリカ間で負荷分散する必要があります。
Contosoは、トランザクションデータベースからのリアルタイムデータに依存する専用のレポートシステムを追加する予定です。
同社は、高可用性/災害復旧(HA / DR)ソリューションの改善を計画しています。計画的な改善の一環として、ContosoSQL1からすべてのデータベースをオフサイトの場所に直接バックアップします。
繰り返されるシナリオの終わり
ContosoSQL1のバックアッププロセスを構成する必要があります。
あなたは何をするべきか?
繰り返されるシナリオの開始
Contoso、Ltd.には、カスタムアプリケーションをサポートするMicrosoft SQL Serverデータベースがあります。現在のSQL Server環境は、ContosoSQL1とContosoSQL2の2つのサーバーで構成されています。これら2つのサーバーは、自動フェールオーバーで同期コミットを使用するように構成されたContosoAG1という名前のAlways On可用性グループに参加します。セカンダリレプリカは読み取り専用アクセス用に構成されていません。
アプリケーションは、ContosoDBという名前のデータベースでトランザクション処理と履歴データ取得の両方を実行します。アプリケーションには、在庫管理モジュールが含まれています。インベントリ管理モジュールとデータベースでパフォーマンスの問題が発生しています。
ユーザーは、InventoryQuery1という名前のクエリの完了に時間がかかると報告しています。クエリは次のように表示されます。
SELECT ProductNumber、Name、ProductLine
FROM Production.Product
WHERE ProductNumber = N '<特定の製品>'
このクエリに対してSQL Serverが使用するクエリプランは、展示に示されています。 ([展示]タブをクリックします。)頻繁に長期にわたってブロックされるエピソードなど、さまざまなパフォーマンスの問題により、ビジネスユーザーは日常のタスクを完了できません。 tempdbデータベースリソースが原因であると思われます。問題を特定するには、ContosoDBデータベースのブロッキングレポートを作成する必要があります。
示す。

拡張イベントを使用して、ContosoSQL1インスタンスに対して実行されるすべてのTransact-SQLステートメントを確認する予定です。拡張イベントセッションからの出力には、開始イベントと停止イベントの両方が含まれている必要があり、ファイルに書き込む必要があります。データ損失の可能性を最小限に抑え、サーバーのパフォーマンスへの影響を減らすために、拡張イベントセッションを構成する必要があります。
ContosoSQL3という名前の追加のセカンダリレプリカをContosoAG1に展開する予定です。読み取り専用トラフィックは、どのインスタンスがプライマリレプリカであるかに関係なく、2つのセカンダリレプリカ間で負荷分散する必要があります。
Contosoは、トランザクションデータベースからのリアルタイムデータに依存する専用のレポートシステムを追加する予定です。
同社は、高可用性/災害復旧(HA / DR)ソリューションの改善を計画しています。計画的な改善の一環として、ContosoSQL1からすべてのデータベースをオフサイトの場所に直接バックアップします。
繰り返されるシナリオの終わり
ContosoSQL1のバックアッププロセスを構成する必要があります。
あなたは何をするべきか?
Correct Answer: C
Vote an answer
Explanation: Only visible for EduDump members. You can sign-up / login (it's free).
sp_whoシステムストアドプロシージャを実行します。プロセスが長時間実行されているためブロックされています。
アクセスされているリソースを含む、デッドロックに関与しているプロセスの詳細を識別する必要があります。また、デッドロックチェーンを見ることができなければなりません。
あなたは何を使うべきですか?
アクセスされているリソースを含む、デッドロックに関与しているプロセスの詳細を識別する必要があります。また、デッドロックチェーンを見ることができなければなりません。
あなたは何を使うべきですか?
Correct Answer: D
Vote an answer
Explanation: Only visible for EduDump members. You can sign-up / login (it's free).
Microsoft SQL Server環境をobiという名前のデータベースで管理します。 1年前よりもクエリの完了までに時間がかかることがわかります。
tempdbという名前のデータベースのファイルサイズを増やしても、問題が解決しない。
すべてのクエリについて実行時統計を取得する必要があります。
Transact-SQLステートメントをどのように完成させるべきですか? 回答するには、回答領域で適切なTransact-SQLセグメントを構成します。
注:それぞれ正しい選択は1ポイントの価値があります。

tempdbという名前のデータベースのファイルサイズを増やしても、問題が解決しない。
すべてのクエリについて実行時統計を取得する必要があります。
Transact-SQLステートメントをどのように完成させるべきですか? 回答するには、回答領域で適切なTransact-SQLセグメントを構成します。
注:それぞれ正しい選択は1ポイントの価値があります。

Correct Answer:

Explanation

Use the ALTER DATABASE statement to enable the query store. For example:
ALTER DATABASE AdventureWorks2012 SET QUERY_STORE = ON;
The SQL Server Query Store feature provides you with insight on query plan choice and performance. It simplifies performance troubleshooting by helping you quickly find performance differences caused by query plan changes. Query Store automatically captures a history of queries, plans, and runtime statistics, and retains these for your review.
References:
https://docs.microsoft.com/en-us/sql/relational-databases/performance/monitoring-performance-by-using-the-que
SQL Server 2014を展開する予定です。
あなたの会社は、データベースに対する以下の監視要件を特定しています。
* ユーザーがログインしたときに電子メールメッセージを送信する必要があります。
* CPU使用率が90%を超える場合は、電子メールメッセージを送信する必要があります。
どの機能が各監視要件を満たしているかを特定する必要があります。
どの機能を識別する必要がありますか? 回答するには、回答領域の適切な監視要件に適切な機能をドラッグします。

あなたの会社は、データベースに対する以下の監視要件を特定しています。
* ユーザーがログインしたときに電子メールメッセージを送信する必要があります。
* CPU使用率が90%を超える場合は、電子メールメッセージを送信する必要があります。
どの機能が各監視要件を満たしているかを特定する必要があります。
どの機能を識別する必要がありますか? 回答するには、回答領域の適切な監視要件に適切な機能をドラッグします。

Correct Answer:

Explanation

SQL Server 2014を展開する予定です。会社では、以下の監視要件を確認しています。
* Tempdbの空き容量不足を監視する必要があります。
* デッドロックは、デッドロックグラフを使用して分析する必要があります。
どの機能が各監視要件を満たしているかを特定する必要があります。
どの機能を識別する必要がありますか? 回答するには、回答領域の適切な監視要件に適切な機能をドラッグします。

* Tempdbの空き容量不足を監視する必要があります。
* デッドロックは、デッドロックグラフを使用して分析する必要があります。
どの機能が各監視要件を満たしているかを特定する必要があります。
どの機能を識別する必要がありますか? 回答するには、回答領域の適切な監視要件に適切な機能をドラッグします。

Correct Answer:

Explanation

* You can use the sys.dm_db_file_space_usage dynamic management view to monitor the disk space used by the user objects, internal objects, and version stores in the tempdb files. Additionally, to monitor the page allocation or deallocation activity in tempdb at the session or task level, you can use the sys.dm_db_session_space_usage and sys.dm_db_task_space_usage dynamic management views. These views can be used to identify large queries, temporary tables, or table variables that are using a large amount of tempdb disk space.
* Use SQL Server Profiler to identify the cause of a deadlock. A deadlock occurs when there is a cyclic dependency between two or more threads, or processes, for some set of resources within SQL Server.
Using SQL Server Profiler, you can create a trace that records, replays, and displays deadlock events for analysis.
* SQL Server Profiler and SQL Server Management Studio use a deadlock wait-for graph to describe a deadlock. The deadlock wait-for graph contains process nodes, resource nodes, and edges representing
* the relationships between the processes and the resources. References: Troubleshooting Insufficient Disk Space in tempdb References: Analyze Deadlocks with SQL Server Profiler
概要
総括
ADatum Corporationはマイアミとモントリオールにオフィスを構えています。
ネットワークには、adatum.comという名前の単一のActive Directoryフォレストが含まれています。オフィスは、5ミリ秒の待ち時間を持つWANリンクを使用して互いに接続します。 A:DatumはSQL Serverを使用してデータベースプラットフォームを標準化しています
2014エンタープライズ版。
データベース
各オフィスには、Sales、Inventory、Customers、Products、Personnel、およびDevという名前のデータベースが含まれています。
サーバーとデータベースは、データベース管理者のチームによって管理されています。現在、すべてのデータベース管理者は、すべてのサーバーとすべてのデータベースに対して同じレベルの権限を持っています。
Customersデータベースには、CustomersとClassificationsという名前の2つのテーブルがあります。
以下の図は、テーブルの関連部分を示しています。

次の表は、Classificationsテーブルの現在のデータを示しています。

インベントリデータベースは頻繁に更新されます。
データベースはレポート作成によく使用されます。
データベースのフルバックアップは、現在完了するのに3時間かかります。
ストアドプロシージャ
USP_1という名前のストアドプロシージャは、複数のレポートに対して数百万行のデータを生成します。 USP_1は、SalesデータベースとCustomersデータベースの5つの異なるテーブルのデータをTable1という名前のテーブルにまとめます。
Table1が作成された後、レポート作成プロセスはTable1からデータを連続して数回読み取ります。プロセスが完了したら、Table1が削除されます。
USP_2という名前のストアドプロシージャを使用して商品リストを生成します。商品リストには、カテゴリ別に分類された商品の名前が含まれています。
プロシージャがアクセスするテーブルがロックされているため、USP_2の実行に数分かかります。ロックはUSP_1とUSP_3によって引き起こされます。
USP_3という名前のストアドプロシージャを使用して価格を更新します。 USP_3は、トランザクション内から順番に呼び出されるいくつかのUPDATEステートメントで構成されています。
現在、UPDATE文の1つが失敗すると、ストアドプロシージャは失敗します。 USP_4という名前のストアドプロシージャは、Sales、Customers、およびInventoryデータベースのストアドプロシージャを呼び出します。
ネストしたストアドプロシージャは、Sales、Customers、およびInventoryデータベースからテーブルを読み取ります。 USP_4はEXECUTE AS句を使用します。
入れ子になったすべてのストアドプロシージャは、構造化例外処理を使用してエラーを処理します。 USP_5という名前のストアドプロシージャは、同じデータベース内の複数のストアドプロシージャを呼び出します。セキュリティチェックは、USP_5がストアドプロシージャを呼び出すたびに実行されます。
セキュリティチェックがUSP_5のパフォーマンスを低下させているとあなたは疑っています。ユーザアプリケーションによってアクセスされるすべてのストアドプロシージャは、ネストされたストアドプロシージャを呼び出します。
入れ子になったストアドプロシージャは直接呼び出されることはありません。
設計要件
データ復旧
ストレージ障害が発生した場合は、インベントリデータベースからデータを回復できる必要があります。目標復旧時間(RTO)は5分です。
データが誤って失われた場合は、Devデータベースからデータを回復できなければなりません。 1日の目標復旧時点(RPO)があります。
分類の変更
顧客の分類方法を変更する予定です。新しい分類には、注文数に基づいて4つのレベルがあります。分類は将来削除または追加される可能性があります。経営陣は過去の分類について過去のデータを維持することを要求している。セキュリティジュニアデータベース管理者のグループは、Salesデータベースのセキュリティを管理できなければなりません。ジュニアデータベース管理者は他の管理権限を持ちません。 A:Datumは、どのユーザーが各ストアドプロシージャを実行しているのかを追跡したいと考えています。
ストレージ
ADatumのストレージは限られています。可能であれば、すべてのデータベースとすべてのバックアップについて、すべての記憶域を最小限に抑える必要があります。
エラー処理
現在、どのストアドプロシージャにもエラー処理コードはありません。
呼び出されたストアドプロシージャとネストされたストアドプロシージャにエラーを記録することを計画しています。入れ子になったストアドプロシージャが直接呼び出されることはありません。
あなたはUSP_4のエラー処理のための解決策を推奨する必要があります。
解決策は、USP_4のコード内のネストされたストアドプロシージャのエラーを処理する必要があります。
何をお勧めですか?
総括
ADatum Corporationはマイアミとモントリオールにオフィスを構えています。
ネットワークには、adatum.comという名前の単一のActive Directoryフォレストが含まれています。オフィスは、5ミリ秒の待ち時間を持つWANリンクを使用して互いに接続します。 A:DatumはSQL Serverを使用してデータベースプラットフォームを標準化しています
2014エンタープライズ版。
データベース
各オフィスには、Sales、Inventory、Customers、Products、Personnel、およびDevという名前のデータベースが含まれています。
サーバーとデータベースは、データベース管理者のチームによって管理されています。現在、すべてのデータベース管理者は、すべてのサーバーとすべてのデータベースに対して同じレベルの権限を持っています。
Customersデータベースには、CustomersとClassificationsという名前の2つのテーブルがあります。
以下の図は、テーブルの関連部分を示しています。

次の表は、Classificationsテーブルの現在のデータを示しています。

インベントリデータベースは頻繁に更新されます。
データベースはレポート作成によく使用されます。
データベースのフルバックアップは、現在完了するのに3時間かかります。
ストアドプロシージャ
USP_1という名前のストアドプロシージャは、複数のレポートに対して数百万行のデータを生成します。 USP_1は、SalesデータベースとCustomersデータベースの5つの異なるテーブルのデータをTable1という名前のテーブルにまとめます。
Table1が作成された後、レポート作成プロセスはTable1からデータを連続して数回読み取ります。プロセスが完了したら、Table1が削除されます。
USP_2という名前のストアドプロシージャを使用して商品リストを生成します。商品リストには、カテゴリ別に分類された商品の名前が含まれています。
プロシージャがアクセスするテーブルがロックされているため、USP_2の実行に数分かかります。ロックはUSP_1とUSP_3によって引き起こされます。
USP_3という名前のストアドプロシージャを使用して価格を更新します。 USP_3は、トランザクション内から順番に呼び出されるいくつかのUPDATEステートメントで構成されています。
現在、UPDATE文の1つが失敗すると、ストアドプロシージャは失敗します。 USP_4という名前のストアドプロシージャは、Sales、Customers、およびInventoryデータベースのストアドプロシージャを呼び出します。
ネストしたストアドプロシージャは、Sales、Customers、およびInventoryデータベースからテーブルを読み取ります。 USP_4はEXECUTE AS句を使用します。
入れ子になったすべてのストアドプロシージャは、構造化例外処理を使用してエラーを処理します。 USP_5という名前のストアドプロシージャは、同じデータベース内の複数のストアドプロシージャを呼び出します。セキュリティチェックは、USP_5がストアドプロシージャを呼び出すたびに実行されます。
セキュリティチェックがUSP_5のパフォーマンスを低下させているとあなたは疑っています。ユーザアプリケーションによってアクセスされるすべてのストアドプロシージャは、ネストされたストアドプロシージャを呼び出します。
入れ子になったストアドプロシージャは直接呼び出されることはありません。
設計要件
データ復旧
ストレージ障害が発生した場合は、インベントリデータベースからデータを回復できる必要があります。目標復旧時間(RTO)は5分です。
データが誤って失われた場合は、Devデータベースからデータを回復できなければなりません。 1日の目標復旧時点(RPO)があります。
分類の変更
顧客の分類方法を変更する予定です。新しい分類には、注文数に基づいて4つのレベルがあります。分類は将来削除または追加される可能性があります。経営陣は過去の分類について過去のデータを維持することを要求している。セキュリティジュニアデータベース管理者のグループは、Salesデータベースのセキュリティを管理できなければなりません。ジュニアデータベース管理者は他の管理権限を持ちません。 A:Datumは、どのユーザーが各ストアドプロシージャを実行しているのかを追跡したいと考えています。
ストレージ
ADatumのストレージは限られています。可能であれば、すべてのデータベースとすべてのバックアップについて、すべての記憶域を最小限に抑える必要があります。
エラー処理
現在、どのストアドプロシージャにもエラー処理コードはありません。
呼び出されたストアドプロシージャとネストされたストアドプロシージャにエラーを記録することを計画しています。入れ子になったストアドプロシージャが直接呼び出されることはありません。
あなたはUSP_4のエラー処理のための解決策を推奨する必要があります。
解決策は、USP_4のコード内のネストされたストアドプロシージャのエラーを処理する必要があります。
何をお勧めですか?
Correct Answer: B
Vote an answer
Explanation: Only visible for EduDump members. You can sign-up / login (it's free).
注:この質問は、同じシナリオを提示する一連の質問の一部です。連載の各質問には、記載されている目標を達成できる可能性のある固有の解決策が含まれています。他の人が正しい解決策を持っていないかもしれない間、いくつかの質問セットは複数の正しい解決策を持っているかもしれません。
このセクションで質問に答えた後は、それに戻ることはできません。その結果、これらの質問はレビュー画面に表示されません。
会社には、オンプレミスのMicrosoft SQL Server環境とMicrosoft Azure SQL Databaseインスタンスがあります。環境は複数の顧客データベースをホストします。
ある顧客は、サービスレベル契約が定めるほど迅速にデータベースが応答していないと報告しています。
データベースが断片化しているのがわかります。
クエリのパフォーマンスを最適化する必要があります。
解決策:DBCC CHECKDBコマンドを実行します。
解決策は目標を満たしていますか?
このセクションで質問に答えた後は、それに戻ることはできません。その結果、これらの質問はレビュー画面に表示されません。
会社には、オンプレミスのMicrosoft SQL Server環境とMicrosoft Azure SQL Databaseインスタンスがあります。環境は複数の顧客データベースをホストします。
ある顧客は、サービスレベル契約が定めるほど迅速にデータベースが応答していないと報告しています。
データベースが断片化しているのがわかります。
クエリのパフォーマンスを最適化する必要があります。
解決策:DBCC CHECKDBコマンドを実行します。
解決策は目標を満たしていますか?
Correct Answer: B
Vote an answer
Explanation: Only visible for EduDump members. You can sign-up / login (it's free).
総括
あなたはLeafield Solutionsというソフトウェア開発会社のシニアデータベースアドミニストレータ(DBA)です。同社は顧客の要求を満たすようにカスタム設計されたソフトウェアアプリケーションを開発しています。
要件Leafield Solutionsは、顧客からWebベースのEnterprise Resource Planning and Managementアプリケーションの開発を依頼されています。新しいアプリケーションは、最終的に顧客が現在使用しているデスクトップアプリケーションを置き換えます。ユーザーが新しいWebベースのアプリケーションを使用するようにトレーニングされている間、現在のアプリケーションは引き続き使用されます。
Webベースのアプリケーション用にSQL Serverとデータベースインフラストラクチャを設計する必要があります。
データベース
Customers、Sales、Products、Current_Inventory、およびTempReportingという名前のデータベースを実装する予定です。
Salesデータベースには、OrderTotalsという名前のテーブルとSalesInfoという名前のテーブルがあります。
SPUpdateSalesInfoという名前のストアドプロシージャは、OrderTotalsテーブルのデータを読み取り、SalesInfoテーブルのデータを変更します。
その後、ストアード・プロシージャーはもう一度OrderTotals表のデータを読み取り、SalesInfo表の情報にさらに変更を加えます。
Current_Inventoryデータベースには、Inv_Currentという名前の大きなテーブルが含まれています。 Inv_Currentテーブルには、主キーのクラスタ化インデックスと非クラスタ化インデックスがあります。主キー列はidentityプロパティを使用します。
Inv_Currentテーブルのデータは120GBを超えるサイズです。 Current_Inventoryデータベース内のテーブルは、Salesデータベース内の複数のクエリによってアクセスされます。
Current_Inventoryデータベースの別のテーブルには、無制限の階層数を持つ自己結合が含まれています。
このテーブルは、SPUpdate2という名前のストアドプロシージャによって変更されます。
ExternalApp1という名前の外部アプリケーションは、Current_Inventoryデータベースに定期的に照会して統計情報を生成します。 TempReportingデータベースには、GenInfoという名前の単一のテーブルが含まれています。
SPUPdateGenInfoという名前のストアドプロシージャは、複数のデータベースからのデータを結合し、GenInfoテーブルに数百万行のデータを生成します。
GenInfoテーブルはレポートに使用されます。
GenInfo内の情報が生成されると、レポート作成プロセスはInv_Currentテーブルからデータを読み取り、そのデータに基づいてGenInfoテーブル内の情報を照会します。
GenInfoテーブルは、レポート作成プロセスが完了した後に削除されます。 Productsデータベースには、ProductNamesとProductTypesという名前のテーブルがあります。
現在のシステム
現在のデスクトップアプリケーションは、DesABCopAppDBという名前のSQL Server 2005データベースに格納されているデータを使用します。
このデータベースはオンラインのままになり、Current_Inventoryデータベースのデータが変更されるとすぐに、Current_Inventoryデータベースのデータがそのデータベースにコピーされます。
SQLサーバー
新しいシステム用のデータベースをホストするために、新しいSQL Server 2012インスタンスが展開されます。データベースは、可用性の高いストレージを提供するストレージエリアネットワーク(SAN)でホストされます。
設計要件
SQL Serverのインフラストラクチャとデータベース設計は、次の要件を満たす必要があります。
* ExternalApp1によってアクセスされるCurrent_ Inventoryデータベース内の機密情報は安全に保管されなければなりません。
開発者またはアプリケーションによるデータベーステーブルへの直接アクセスは拒否されなければなりません。
* レポートを生成するために使用されるアカウントは、接続を許可される時間に制限がなければなりません。
* デッドロックは、デッドロックグラフを使用して分析する必要があります。
* SQL Serverに障害が発生した場合でも、データベースは利用可能なままにする必要があります。
* ソフトウェアライセンスとデータベースストレージのコストを最小限に抑える必要があります。
* 開発努力は最小にされなければなりません。
* Tempdbデータベースの空き容量不足を監視する必要があります。
* 失敗した認証要求はログに記録する必要があります。
* ProductsデータベースのProductTypesテーブルに新しい行が追加されるたびに、その行がテーブルに追加される前に、その行を検証するユーザー定義関数を呼び出す必要があります。
* SPUpdateSalesInfoがOrderTotalsテーブルのデータを初めてクエリするとき、SPUpdateSalesInfoがOrderTotalsテーブルのデータを2度目にクエリするときに、同じ行が新しく追加されたすべての行と共に返される必要があります。
SPUpdate2ストアドプロシージャのパフォーマンスを向上させる必要があります。
あなたの解決策は設計要件を満たさなければなりません。
あなたの解決策は何を含めるべきですか?
あなたはLeafield Solutionsというソフトウェア開発会社のシニアデータベースアドミニストレータ(DBA)です。同社は顧客の要求を満たすようにカスタム設計されたソフトウェアアプリケーションを開発しています。
要件Leafield Solutionsは、顧客からWebベースのEnterprise Resource Planning and Managementアプリケーションの開発を依頼されています。新しいアプリケーションは、最終的に顧客が現在使用しているデスクトップアプリケーションを置き換えます。ユーザーが新しいWebベースのアプリケーションを使用するようにトレーニングされている間、現在のアプリケーションは引き続き使用されます。
Webベースのアプリケーション用にSQL Serverとデータベースインフラストラクチャを設計する必要があります。
データベース
Customers、Sales、Products、Current_Inventory、およびTempReportingという名前のデータベースを実装する予定です。
Salesデータベースには、OrderTotalsという名前のテーブルとSalesInfoという名前のテーブルがあります。
SPUpdateSalesInfoという名前のストアドプロシージャは、OrderTotalsテーブルのデータを読み取り、SalesInfoテーブルのデータを変更します。
その後、ストアード・プロシージャーはもう一度OrderTotals表のデータを読み取り、SalesInfo表の情報にさらに変更を加えます。
Current_Inventoryデータベースには、Inv_Currentという名前の大きなテーブルが含まれています。 Inv_Currentテーブルには、主キーのクラスタ化インデックスと非クラスタ化インデックスがあります。主キー列はidentityプロパティを使用します。
Inv_Currentテーブルのデータは120GBを超えるサイズです。 Current_Inventoryデータベース内のテーブルは、Salesデータベース内の複数のクエリによってアクセスされます。
Current_Inventoryデータベースの別のテーブルには、無制限の階層数を持つ自己結合が含まれています。
このテーブルは、SPUpdate2という名前のストアドプロシージャによって変更されます。
ExternalApp1という名前の外部アプリケーションは、Current_Inventoryデータベースに定期的に照会して統計情報を生成します。 TempReportingデータベースには、GenInfoという名前の単一のテーブルが含まれています。
SPUPdateGenInfoという名前のストアドプロシージャは、複数のデータベースからのデータを結合し、GenInfoテーブルに数百万行のデータを生成します。
GenInfoテーブルはレポートに使用されます。
GenInfo内の情報が生成されると、レポート作成プロセスはInv_Currentテーブルからデータを読み取り、そのデータに基づいてGenInfoテーブル内の情報を照会します。
GenInfoテーブルは、レポート作成プロセスが完了した後に削除されます。 Productsデータベースには、ProductNamesとProductTypesという名前のテーブルがあります。
現在のシステム
現在のデスクトップアプリケーションは、DesABCopAppDBという名前のSQL Server 2005データベースに格納されているデータを使用します。
このデータベースはオンラインのままになり、Current_Inventoryデータベースのデータが変更されるとすぐに、Current_Inventoryデータベースのデータがそのデータベースにコピーされます。
SQLサーバー
新しいシステム用のデータベースをホストするために、新しいSQL Server 2012インスタンスが展開されます。データベースは、可用性の高いストレージを提供するストレージエリアネットワーク(SAN)でホストされます。
設計要件
SQL Serverのインフラストラクチャとデータベース設計は、次の要件を満たす必要があります。
* ExternalApp1によってアクセスされるCurrent_ Inventoryデータベース内の機密情報は安全に保管されなければなりません。
開発者またはアプリケーションによるデータベーステーブルへの直接アクセスは拒否されなければなりません。
* レポートを生成するために使用されるアカウントは、接続を許可される時間に制限がなければなりません。
* デッドロックは、デッドロックグラフを使用して分析する必要があります。
* SQL Serverに障害が発生した場合でも、データベースは利用可能なままにする必要があります。
* ソフトウェアライセンスとデータベースストレージのコストを最小限に抑える必要があります。
* 開発努力は最小にされなければなりません。
* Tempdbデータベースの空き容量不足を監視する必要があります。
* 失敗した認証要求はログに記録する必要があります。
* ProductsデータベースのProductTypesテーブルに新しい行が追加されるたびに、その行がテーブルに追加される前に、その行を検証するユーザー定義関数を呼び出す必要があります。
* SPUpdateSalesInfoがOrderTotalsテーブルのデータを初めてクエリするとき、SPUpdateSalesInfoがOrderTotalsテーブルのデータを2度目にクエリするときに、同じ行が新しく追加されたすべての行と共に返される必要があります。
SPUpdate2ストアドプロシージャのパフォーマンスを向上させる必要があります。
あなたの解決策は設計要件を満たさなければなりません。
あなたの解決策は何を含めるべきですか?
Correct Answer: B
Vote an answer
注:この質問は、同じシナリオを提示する一連の質問の一部です。連載の各質問には、目標を達成する可能性のある固有の解決策が含まれています。他の人が正しい解決策を持っていないかもしれない間、いくつかの質問セットは複数の正しい解決策を持っているかもしれません。
このセクションで質問に回答した後は、その質問に戻ることはできません。その結果、これらの質問はレビュー画面に表示されません。
640 GBで、頻繁に更新されるDB1という名前のデータベースがあります。
DB1のログ配布を有効にし、30分ごとにバックアップと復元を実行するように構成しました。
データサーバーのディスクがほぼいっぱいになっていることがわかります。
ログ配布プロセスで使用されるディスク容量を減らす必要があります。
解決方法:トランザクションログバックアップの圧縮を有効にします。
これは目標を達成していますか?
このセクションで質問に回答した後は、その質問に戻ることはできません。その結果、これらの質問はレビュー画面に表示されません。
640 GBで、頻繁に更新されるDB1という名前のデータベースがあります。
DB1のログ配布を有効にし、30分ごとにバックアップと復元を実行するように構成しました。
データサーバーのディスクがほぼいっぱいになっていることがわかります。
ログ配布プロセスで使用されるディスク容量を減らす必要があります。
解決方法:トランザクションログバックアップの圧縮を有効にします。
これは目標を達成していますか?
Correct Answer: A
Vote an answer
Explanation: Only visible for EduDump members. You can sign-up / login (it's free).
0
0
0
10
